Fedora Users Forum

Fedoraユーザのためのサポートフォーラム
現在時刻 - 2017年11月24日(金) 18:27

All times are UTC + 9 hours





新しいトピックを投稿する トピックへ返信する  [ 9 件の記事 ] 
作成者 メッセージ
 記事の件名: [解決済み] ibus-mozcが使えません
投稿記事Posted: 2013年2月25日(月) 15:34 
オフライン
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2009年4月08日(水) 22:07
記事: 101
所在地: 東京
こんにちは。

Fedora18でibus-mozcが使えません。

入力メソッドのセレクターでibusを選択すると

コード:
GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.Code5: Current desktop isn't targeted by Input Method.


というエラーが出て。ibusが選択できません。

どうしたら良いでしょうか?

宜しくお願いします。


最後に編集したユーザー hiroppy [ 2013年2月27日(水) 16:14 ], 累計 1 回

トップへ
 
 記事の件名: Re: ibus-mozcが使えません
投稿記事Posted: 2013年2月25日(月) 20:50 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146


まるっきり参照ですが、こちらの日本語入力の修正の箇所を実行してみられては?


トップへ
 
 記事の件名: Re: ibus-mozcが使えません
投稿記事Posted: 2013年2月26日(火) 11:31 
オフライン
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2009年4月08日(水) 22:07
記事: 101
所在地: 東京
こんにちは。

セッションの選択でLXDEを選択するとibus-mozcが使えるので

ユーザーのアカウントは削除したくないんですが他に方法はないでしょうか?


最後に編集したユーザー hiroppy [ 2013年2月26日(火) 19:32 ], 累計 2 回

トップへ
 
 記事の件名: Re: ibus-mozcが使えません
投稿記事Posted: 2013年2月26日(火) 13:28 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146

ハングル文字の事例ですが、ctrl+spaceで切り替わる様ですが、いかがでしょう? :?:
hiroppy さんが書きました:
こんにちは。

セッションの選択でLXDEを選択するとibus-mozcが使えるので

アカウントは削除したくないんですが他に方法はないでしょうかあ?


トップへ
 
 記事の件名: Re: ibus-mozcが使えません
投稿記事Posted: 2013年2月26日(火) 15:02 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146
私も実際 入力切り換えは 上部パネルの入力メソッドの切り換えで行ってますが :oops:


トップへ
 
 記事の件名: Re: ibus-mozcが使えません
投稿記事Posted: 2013年2月26日(火) 19:29 
オフライン
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2009年4月08日(水) 22:07
記事: 101
所在地: 東京
こんばんは。

セッションの選択というのはログイン時kdeとかgnomeとかlxdeなどのデスクトップの切り替えの事を言っているんですが・・・

なぜかlxdeのときはibus-mozcが使えます。gnomeの時はAnthyしか使えません。


トップへ
 
 記事の件名: Re: ibus-mozcが使えません
投稿記事Posted: 2013年2月27日(水) 14:59 
オフライン
アバター
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年3月20日(金) 22:04
記事: 239
 こんにちは

Gnome-shellにてibus-mozcが使えない で宜しいのでしょうか? 

LXDEでは Mozc の使用が可能であるとのことですが、それはどこで判断されたのでしょうか? 上段タスクバーにMozcマークが出ているからでしょうか?

わたしの環境は、
$ gnome-shell --version
GNOME Shell 3.6.3
でして、
「システム設定」→「地域と言語」→「入力ソース」にて 「日本語 MOZC」を選択し、GNOME ShellでMozcを使用しています。

システムモニターで確認しても構わないのですが、GNOME Shell上で

$ ps -ax

コマンドを打つと(数値は私の環境)、

1493 ? Sl 0:01 /usr/bin/ibus-daemon --replace --xim --panel disable
1499 ? Sl 0:00 /usr/libexec/ibus-dconf
1502 ? Sl 0:00 /usr/libexec/ibus-x11 --kill-daemon
1843 ? Sl 0:00 /usr/libexec/ibus-engine-mozc --ibus
1850 ? Sl 0:00 /usr/lib64/mozc/mozc_server
5249 ? Sl 0:00 /usr/lib64/mozc/mozc_renderer

というように、Mozcを使用するためのプロセス(デーモン)があります。恐らく、hiroppyさんの環境でも同じようにプロセスが動いているのでは?

FC18では私が知る限り、言語ツールバーは出ませんし、GNOME Shell上ではタスクバー上段にもアイコンマークは出ないと思いますので、Anthyを使っているのか、Mozcを使っているのか判断しづらいと思います。

ibus-engine-mozc、mozc_server、mozc_rendererが動いていればMozcを使っていると判断していますけど。

※わたしの場合

Mozc辞書を追加しているので、Mozcは yum管理 ではありません。よってモジュールをコピーするイメージなので、言語変換することにより、Mozcが動くことを前提にMozc辞書機能が反映しているかを判断材料のひとつにしています。


トップへ
 
 記事の件名: Re: ibus-mozcが使えません
投稿記事Posted: 2013年2月27日(水) 15:58 
オフライン
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2009年4月08日(水) 22:07
記事: 101
所在地: 東京
こんにちは。

こちらの環境は

$ gnome-shell --version
GNOME Shell 3.6.2

でした。

「システム設定」→「地域と言語」→「入力ソース」にて 「日本語 MOZC」を選択したら

ibus-mozcが使えるようになりました。有難う御座います。

lxdeでは下方向のパネルにmozcのアイコンが出ます。

gnomeでは「あ」とか「ja」が上部パネルに出ました。ここをクリックするとAnthyとかmozcが選べますよね。

いままでは「入力メソッドのセレクター」→「IBusを利用する」→「設定」で上手くいきませんでしたが、

「システム設定」→「地域と言語」→「入力ソース」にて 「日本語 MOZC」を選択したら

ibus-mozcが使えるようになりました。有難う御座います。


トップへ
 
 記事の件名: Re: ibus-mozcが使えません
投稿記事Posted: 2013年2月27日(水) 16:32 
オフライン
アバター
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年3月20日(金) 22:04
記事: 239
---------
こんにちは、

hiroppy さんが書きました:
lxdeでは下方向のパネルにmozcのアイコンが出ます。

gnomeでは「あ」とか「ja」が上部パネルに出ました。ここをクリックするとAnthyとかmozcが選べますよね。

いままでは「入力メソッドのセレクター」→「IBusを利用する」→「設定」で上手くいきませんでしたが、

「システム設定」→「地域と言語」→「入力ソース」にて 「日本語 MOZC」を選択したら



すみません。下方向パネルでしたね(LXDE)。

 ご理解されている内容ですが、少々FC18の入力設定は理解しにくい設計になっているようで、半角/全角 変換を選ぶには 「入力メソッドのセレクター」から設定する必要があり、インプットメソッド(Mozc等)の優先権があるのは、「システム設定」から選択する方法のようです。

開発陣がどのように考えているのかは理解しきれていませんが、「入力メソッドのセレクター」よりIBusを選ぶと、わたしの環境でも
コード:
GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._imsettings_2derror_2dquark.Code5: Current desktop isn't targeted by Input Method.
が出ます。わたしの解釈では、この事象をバグと認識していないようなので??、それはどうなのかな?とは思っていますが。

アイコンマークなしで確認するには、郵便番号で変換されるか? というのはMozcのテストに適しているかもしれませんね。
100-6801 と入力し変換した場合 東京都千代田区大手町JAビル(ここまで普通に出るのかな?)と出ればMozcでしょう。

hiroppy さんが書きました:
gnomeでは「あ」とか「ja」が上部パネルに出ました。ここをクリックするとAnthyとかmozcが選べますよね。
 

この選択方法で問題ないと思いますし、今のところはこの切り替えがポピュラーなのだと思います。


トップへ
 
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 9 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]


トピック投稿: 不可
返信投稿: 不可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
cron

無料でマイフォーラムを作成する! · php-BB© · Internationalization Project · 不正利用を報告する · 使用条件/プライバシーポリシー
© Forums-Free.com 2009