Fedora Users Forum

Fedoraユーザのためのサポートフォーラム
現在時刻 - 2017年4月26日(水) 18:57

All times are UTC + 9 hours





新しいトピックを投稿する トピックへ返信する  [ 7 件の記事 ] 
作成者 メッセージ
 記事の件名: [解決済み] hplip-guiがインストール出来ません。
投稿記事Posted: 2013年2月05日(火) 12:55 
オフライン
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2009年4月08日(水) 22:07
記事: 101
所在地: 東京
hplip-guiがインストール出来ません。

 コード: 全選択 大枠 小枠
[miku@localhost ~]$ sudo yum install hplip-gui
[sudo] password for miku:
読み込んだプラグイン:langpacks, presto, refresh-packagekit
エラー: Cannot retrieve metalink for repository: fedora. Please verify its path and try again
[miku@localhost ~]$


となったり、ミラーが見つかりませんとなったり、します。

どうしたら良いでしょうか?


トップへ
 
 記事の件名: Re: hplip-guiがインストール出来ません。
投稿記事Posted: 2013年2月06日(水) 00:51 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
Fedoraのバージョンが異なるかも知れませんが、こちらのサイトに同じようなケースについて書かれています。



以下の手順でいかがでしょうか?

[STEP 1]
以下のように、/etc/yum.d.repo の fedora.repo , fedora-update.repo を編集して、fedora.repo , fedora-update.repo 内の すべての baseurl を非コメント化し、すべての mirrorlist をコメントアウトにする。

 コード: 全選択 大枠 小枠
baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch

[STEP 2]
yum-fastestmirror をインストールしてアップデートする。

$ sudo yum install -y yum-fastestmirror
$ sudo yum update

[STEP 3]
もう一度、hplip-guiをインストールしてみる。

$ sudo yum install hplip-gui


トップへ
 
 記事の件名: Re: hplip-guiがインストール出来ません。
投稿記事Posted: 2013年2月06日(水) 12:55 
オフライン
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2009年4月08日(水) 22:07
記事: 101
所在地: 東京
こんにちは。

大体上手くいきました。

hplip-guiもインストール出来ました。

有難う御座います。

しかし、いくつかのパッケージがダウンロードエラーになってしまいました。


 コード: 全選択 大枠 小枠
パッケージのダウンロードでエラー:
kgreeter-plugins-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kwin-gles-libs-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kde-settings-kdm-4.8-22.fc17.noarch: [Errno 256] No more mirrors to try.
ksysguard-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
libkworkspace-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
ksysguard-libs-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kde-settings-4.8-22.fc17.noarch: [Errno 256] No more mirrors to try.
plasma-scriptengine-python-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kde-workspace-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kdm-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kcm_colors-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kde-workspace-devel-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kde-settings-ksplash-4.8-22.fc17.noarch: [Errno 256] No more mirrors to try.
qt-settings-4.8-22.fc17.noarch: [Errno 256] No more mirrors to try.
ksysguardd-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.
kde-settings-pulseaudio-4.8-22.fc17.noarch: [Errno 256] No more mirrors to try.
kde-settings-plasma-4.8-22.fc17.noarch: [Errno 256] No more mirrors to try.
kde-workspace-libs-4.9.5-1.fc17.i686: [Errno 256] No more mirrors to try.


トップへ
 
 記事の件名: Re: hplip-guiがインストール出来ません。
投稿記事Posted: 2013年2月06日(水) 23:28 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
該当するバージョンのパッケージが含まれるリポジトリが無効になっているかもしれません。

fedora.repoとfedora-update.repoの内容を貼り付けてみてください。


トップへ
 
 記事の件名: Re: hplip-guiがインストール出来ません。
投稿記事Posted: 2013年2月07日(木) 13:22 
オフライン
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2009年4月08日(水) 22:07
記事: 101
所在地: 東京
こんにちは。

お世話になります。

添付しますので宜しくお願いします。

拡張子 は許可されていませんとなるためcode2で表示します。

 コード: 全選択 大枠 小枠
fedora.repo
[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
failovermethod=priority
baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[fedora-source]
name=Fedora $releasever - Source
failovermethod=priority
baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch


 コード: 全選択 大枠 小枠
fedora-update.repo
[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[updates-debuginfo]
name=Fedora $releasever - $basearch - Updates - Debug
failovermethod=priority
baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/debug/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-debug-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch

[updates-source]
name=Fedora $releasever - Updates Source
failovermethod=priority
baseurl=http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/SRPMS/
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=updates-released-source-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$basearch


宜しくお願いします。


トップへ
 
 記事の件名: Re: hplip-guiがインストール出来ません。
投稿記事Posted: 2013年2月07日(木) 16:49 
オフライン
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2009年4月08日(水) 22:07
記事: 101
所在地: 東京
こんにちは。

今日GUIでアップデート(1000個以上)が成功して

端末の結果も

 コード: 全選択 大枠 小枠
[miku@localhost ~]$ sudo yum update
[sudo] password for miku:
読み込んだプラグイン:fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
* rpmfusion-free: mirrors.163.com
* rpmfusion-free-updates: mirrors.163.com
* rpmfusion-nonfree: mirrors.163.com
* rpmfusion-nonfree-updates: mirrors.163.com
更新と設定されたパッケージがありません。
[miku@localhost ~]$


と問題はなくなりました。


トップへ
 
 記事の件名: Re: hplip-guiがインストール出来ません。
投稿記事Posted: 2013年2月07日(木) 23:46 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
---------
すみません、さっき帰宅しました。

解決ということですよね?
タイトルに[解決済み]を加えておきます。


トップへ
 
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 7 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]


トピック投稿: 不可
返信投稿: 不可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
cron

無料でマイフォーラムを作成する! · php-BB© · Internationalization Project · 不正利用を報告する · 使用条件/プライバシーポリシー
© Forums-Free.com 2009