Fedora Users Forum

Fedoraユーザのためのサポートフォーラム
現在時刻 - 2017年11月23日(木) 08:45

All times are UTC + 9 hours





新しいトピックを投稿する トピックへ返信する  [ 12 件の記事 ]  ページ移動 1, 2  次へ
作成者 メッセージ
 記事の件名: [解決済み]ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月19日(木) 16:28 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2012年4月15日(日) 02:13
記事: 40
誤:Fedora13αでソフトウェアの更新を行うとエラーが出ます。
正:Fedora17αでソフトウェアの更新を行うとエラーが出ます。
LAME Ain't an MP3 Encoder ... but it's the best of all
lame-3.99.5-1.e15.rf (32 bit)

Header files, libraries and development documentaition for lame.
lame-devel-3.99.5-1.e15.rf (32bit)

Tools for working with paths and file specs across platforms
perl-PathTools-3.2701.el5.rf (32bit)

まず、まとめて更新しようとすると以下のエラーが出ます。

lame-mp3x-3.98.4-1.fc14.i686 は lame = 3.98.4-1.fc14 を要求します
perl-PathTools-3.2701-1.el5.rf.i386 は perl(VMS::Filespec) を要求します : 成功 - 空のトランザクション

次に個別に更新しようとすると、以下のエラーが出ます。

LAME Ain't an MP3 Encoder ... but it's the best of all
lame-3.99.5-1.e15.rf (32 bit)

lame-mp3x-3.98.4-1.fc14.i686 は lame = 3.98.4-1.fc14 を要求します : 成功 - 空のトランザクション

Header files, libraries and development documentaition for lame.
lame-devel-3.99.5-1.e15.rf (32bit)

lame-mp3x-3.98.4-1.fc14.i686 は lame = 3.98.4-1.fc14 を要求します : 成功 - 空のトランザクション

Tools for working with paths and file specs across platforms
perl-PathTools-3.2701.el5.rf (32bit)

perl-PathTools-3.2701-1.el5.rf.i386 は perl(VMS::Filespec) を要求します : 成功 - 空のトランザクション

ちなみに、lame-mp3x-3.98.4-1.fc14.i686.rpmはインストール済みです。

どなたかご教示願います。


最後に編集したユーザー trazom [ 2012年4月21日(土) 05:25 ], 累計 2 回

トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月19日(木) 16:34 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2012年4月15日(日) 02:13
記事: 40
すみません、勘違いでした。
lame-mp3x-3.98.4-1.fc14.i686.rpm
はインストールされていません。


トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月19日(木) 16:37 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2012年4月15日(日) 02:13
記事: 40
ちなみにインストルしようとすると怒られてしまいます。
[trazomaw@trazzomaw ~]$ sudo yum install lame-mp3x-3.98.4-1.fc14.i686.rpm
読み込んだプラグイン:langpacks, presto, refresh-packagekit
パッケージ lame-mp3x-3.98.4-1.fc14.i686.rpm は利用できません。
エラー: 何もしません


トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月19日(木) 17:09 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2012年4月15日(日) 02:13
記事: 40
yum update を行うと以下のとおりになります。

[trazomaw@trazzomaw ~]$ sudo yum update
[sudo] password for trazomaw:
読み込んだプラグイン:langpacks, presto, refresh-packagekit
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ lame.i686 0:3.98.4-1.fc14 は 更新 です
--> 依存性の処理をしています: lame = 3.98.4-1.fc14 のパッケージ: lame-mp3x-3.98.4-1.fc14.i686
---> パッケージ lame.i386 0:3.99.5-1.el5.rf は アップデート です
---> パッケージ lame-devel.i686 0:3.98.4-1.fc14 は 更新 です
---> パッケージ lame-devel.i386 0:3.99.5-1.el5.rf は アップデート です
---> パッケージ perl-PathTools.i686 0:3.33-211.fc17 は 更新 です
---> パッケージ perl-PathTools.i386 0:3.2701-1.el5.rf は アップデート です
--> 依存性の処理をしています: perl(VMS::Filespec) のパッケージ: perl-PathTools-3.2701-1.el5.rf.i386
--> 依存性解決を終了しました。
エラー: パッケージ: perl-PathTools-3.2701-1.el5.rf.i386 (rpmforge)
要求: perl(VMS::Filespec)
エラー: パッケージ: lame-mp3x-3.98.4-1.fc14.i686 (@rpmfusion-free)
要求: lame = 3.98.4-1.fc14
削除中: lame-3.98.4-1.fc14.i686 (@rpmfusion-free)
lame = 3.98.4-1.fc14
次のものにより更新された: : lame-3.99.5-1.el5.rf.i386 (rpmforge)
lame = 3.99.5-1.el5.rf
利用可能: lame-3.97-1.el5.rf.i386 (rpmforge)
lame = 3.97-1.el5.rf
利用可能: lame-3.98.2-1.el5.rf.i386 (rpmforge)
lame = 3.98.2-1.el5.rf
利用可能: lame-3.98.4-1.el5.rf.i386 (rpmforge)
lame = 3.98.4-1.el5.rf
利用可能: lame-3.99.4-1.el5.rf.i386 (rpmforge)
lame = 3.99.4-1.el5.rf
利用可能: lame-3.99.4-2.el5.rf.i386 (rpmforge)
lame = 3.99.4-2.el5.rf
問題を回避するために --skip-broken を用いることができます。
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
openjpeg-libs-1.5.0-1.fc18.i686 は openjpeg-libs-1.4-12.fc17.i686 の複製です
[trazomaw@trazzomaw ~]$


トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月19日(木) 17:13 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2012年4月15日(日) 02:13
記事: 40
--skip-broken オプションをつけると、以下のとおりになります。

[trazomaw@trazzomaw ~]$ sudo yum update --skip-broken
読み込んだプラグイン:langpacks, presto, refresh-packagekit
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ lame.i686 0:3.98.4-1.fc14 は 更新 です
--> 依存性の処理をしています: lame = 3.98.4-1.fc14 のパッケージ: lame-mp3x-3.98.4-1.fc14.i686
---> パッケージ lame.i386 0:3.99.5-1.el5.rf は アップデート です
---> パッケージ lame-devel.i686 0:3.98.4-1.fc14 は 更新 です
---> パッケージ lame-devel.i386 0:3.99.5-1.el5.rf は アップデート です
---> パッケージ perl-PathTools.i686 0:3.33-211.fc17 は 更新 です
---> パッケージ perl-PathTools.i386 0:3.2701-1.el5.rf は アップデート です
--> 依存性の処理をしています: perl(VMS::Filespec) のパッケージ: perl-PathTools-3.2701-1.el5.rf.i386
--> トランザクションの確認を実行しています。
---> パッケージ lame-devel.i686 0:3.98.4-1.fc14 は 更新 です
---> パッケージ lame-devel.i386 0:3.99.5-1.el5.rf は アップデート です
--> 依存性の処理をしています: lame = 3.99.5-1.el5.rf のパッケージ: lame-devel-3.99.5-1.el5.rf.i386

パッケージは依存関係に問題があるため、飛ばします:
lame-3.99.5-1.el5.rf.i386 (rpmforge から)
lame-devel-3.99.5-1.el5.rf.i386 (rpmforge から)
perl-PathTools-3.2701-1.el5.rf.i386 (rpmforge から)

とぎれとぎれに投稿してしまって申し訳ありません。


トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月19日(木) 23:55 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
どこからつっこんだらいいのかわかりませんが…

まず、Fedora13はサポート期限が切れています。
なぜFedora13αからのアップデートなのかが、よくわかりません。

あと、アップデートされようとしているパッケージに、el5やfc17が混在しているようですので、何かいろいろとリポジトリを追加されているような気もします。

そのあたりの情報を示していただかないと、何とも言えませんね。

※ ちなみに、rpmdbのエラーは、F16からF17 Betaへのアップグレードでも出ていました。僕はF17の正規版が出た時点で、入れ替えようと思っています。


トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月20日(金) 00:45 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2012年4月15日(日) 02:13
記事: 40
自分ではどうしてもlame-mp3x-3.98.4-1.fc14.i686.rpm をインストールしていた気がしたので、再起動して
sudo yum remove lame-mp3x-3.98.4-1.fc14.i686.rpm を実行したら今度は削除できました。

それで、もう一度更新プログラムを実行したら、テストトランザクションでエラー: file /usr/lib/libmp3lame.so.0.0.0 from install of lame-3.99.5-1.el5.rf.i386 conflicts with file from package lame-libs-3.98.4-1.fc14.i686
といわれたのでsudo yum remove lame-3.99.5-1.el5.rf.i386を実行して
それから sudo yum install lame-devel-3.99.5-1.el5.rf.i386.rpmを実行したらエラーが2つなくなりました。


このエラーだけになりました。
Tools for working with paths and file specs across platforms
perl-PathTools-3.2701-1.el5.rf (32 bit)

tools for working
perl-PathTools-3.2701-1.el5.rf.i386 は perl(VMS::Filespec) を要求します : 成功 - 空のトランザクション

インストールしたら

sudo yum install perl-PathTools-3.2701-1.el5.rf.i386.rpm
読み込んだプラグイン:langpacks, presto, refresh-packagekit
パッケージ perl-PathTools-3.2701-1.el5.rf.i386.rpm は利用できません。
エラー: 何もしません

となりました


最後に編集したユーザー trazom [ 2012年4月20日(金) 01:57 ], 累計 2 回

トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月20日(金) 00:47 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2012年4月15日(日) 02:13
記事: 40
すみません、Fedora17αのまちがいです。
重ね重ね申し訳ないです。
テンパッてしまって・・・・
リポジトリは
adobe-linux-i386.repo
mirrors-rpmforge-testing
dropbox.repo
rpmforge.repo
fedora-cinnamon.repo
fedora-updates-testing.repo
fedora-updates.repo
fedora.repo
freshrpms.repo
freshrpms.repo~
rpmfusion-nonfree-rawhide.repo
rpmfusion-free-rawhide.repo
rpmfusion-free-updates-testing.repo
rpmfusion-free-updates.repo
rpmfusion-free.repo
rpmfusion-nonfree-updates-testing.repo
rpmfusion-nonfree-updates.repo
rpmfusion-nonfree.repolivna.repo
google-chrome.repo
mirrors-rpmforge
sawaa.repo
mirrors-rpmforge-extras
です


トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月20日(金) 01:57 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
rpmforge.repo,mirrors-rpmforge-testing,mirrors-rpmforge,sawaa.repo,mirrors-rpmforge-extrasは、いずれもCentOSのリポジトリではないかと思います。

fc14やel5のパッケージが更新されようとしているのは、これらが原因ですね。

freshrpms.repoは、rpmfusionに統合されていて、F12以降のディレクトリはすでにありません。


Fedora17はまだ開発段階ですし、普通にアップデートするだけでもいろいろとトラブりますので、サードパーティーのリポジトリをやたらに突っ込むのは避けた方が無難です。

※ ここまで複雑ですと、手の打ちようがないように思います。可能であれば、いま一度、インストールしなおした方がいいような…。


トップへ
 
 記事の件名: Re: ソフトウェアの更新でエラーが出る
投稿記事Posted: 2012年4月20日(金) 07:01 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2012年4月15日(日) 02:13
記事: 40
---------
sawaa.repo は、確実にFedora16のものです。絶対に。
あとはよくわかりません。
HP見ながらこれはFedoraかなぁ・・・
って具合に追加ました。
リポジトリを削除するなりしてみて、ダメだったら再インストールしようと思います。


トップへ
 
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 12 件の記事 ]  ページ移動 1, 2  次へ

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]


トピック投稿: 不可
返信投稿: 不可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
cron

無料でマイフォーラムを作成する! · php-BB© · Internationalization Project · 不正利用を報告する · 使用条件/プライバシーポリシー
© Forums-Free.com 2009