Fedora Users Forum

Fedoraユーザのためのサポートフォーラム
現在時刻 - 2019年7月21日(日) 16:28

All times are UTC + 9 hours





新しいトピックを投稿する トピックへ返信する  [ 19 件の記事 ]  ページ移動 1, 2  次へ
作成者 メッセージ
 記事の件名: [解決済み]アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月02日(木) 21:57 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年11月03日(月) 21:48
記事: 271
こんばんわ、

fedora 9 を fedora 10 へインストールディスクを用いてアップグレードしましたが、
firefox が起動せず、困っています

状況としては、普通にfedora 10 を起動して、firefox のアイコンをクリックすると、
firefox の起動中と下のタブのようなところに表示されますが、
実際のfirefox の画面が出ません

「fedora 10  アップグレード firefox起動 エラー」
と検索してみたのですが、見つかりませんでした

この場合、どうやって異常を見つければよいのでしょうか?
すみませんが、アドバイスお願いします


最後に編集したユーザー りなっくす初心者 [ 2009年7月10日(金) 20:56 ], 累計 1 回

トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月02日(木) 22:20 
オフライン
プライベートメッセージ送信  WWW  プロフィール

登録日時: 2008年9月13日(土) 12:37
記事: 250
所在地: 兵庫県
まず、検索をするなら
「firefox 起動しない」
とかがよろしいかと。Fedora10へアップグレードしたことが原因かどうかはまだ分かりませんが、起動しない時の対処方法についてはこのキーワードで調べて確認することができるでしょう。
その後、Fedora10の固有の事例がないかを調べるべきです。

上記の検索ワードならすぐでてくると思いますが、まず試すのはセーフモードでの起動です。firefoxの起動オプションにそういうものがあります。

また、$HOME/.mozillaをリネームして、素の状態で起動するかを確かめるとか。
もちろん、端末から起動して、エラーメッセージが出るかを確認すると言うのもありますね。

ざっと思いつく定番だけでもこれくらいはあります。

端末は、メニューバーの「システム」とかに入ってないですかね? 私はKDEなのでGnomeはさっぱりですが、メニューの中にあるはず。

あと、Linux関連にできるだけ絞って検索するなら、

を使いましょう。いくらか効率を上げてくれるはずです。


トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月03日(金) 09:01 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年11月03日(月) 21:48
記事: 271
おはようございます

code_air_edgeさん、<Linux> - Google 検索
の存在を教えていただきありがとうございます :)

普通に探すより、かなり効率的ですね

<Linux> - Google 検索で 「firefox 起動しない」で調べて見ましたが、要因が特定できません

そこで、端末から起動して、エラーメッセージが出るかを確認してみました

すると、
引用:
$firefox
Couldn't load XPCOM

と表示されました

どうやら、XPCOM を読み込めないことが原因みたいです

これを <Linux> - Google 検索 で「Couldn't load XPCOM firefox 」で検索してみました

その結果、それらしい記事が

にありました

英語サイトなので、詳しくはわかりませんが、参考になりそうです :)

今日から実家に帰りますので、残念ながら続きは 日曜の夜になります
(現在、fedora 10 / Ubuntu 8.10 でデュアルブートしているPCはデスクのためもっていけません)


トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月03日(金) 21:20 
オフライン
アバター
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年3月20日(金) 22:04
記事: 239
# yum update
で直った! という記事のようですが。

どういう話かは、よくわかりませんが、yum updateで、firefoxのverが変わったのか? ちょっとそこら辺はわかりません。


トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月03日(金) 21:49 
オフライン
プライベートメッセージ送信  WWW  プロフィール

登録日時: 2008年9月13日(土) 12:37
記事: 250
所在地: 兵庫県
この記事ではyum updateをするだけで直ってますね。
ところで、xulrunnerはインストールされてますか?
まぁ、大抵入っているはずなんですが、何かの拍子に入らなかったのかもしれません。
ご確認あれ。


トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月04日(土) 17:22 
オフライン
アバター
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年3月20日(金) 22:04
記事: 239
hideさんの記事で思い出したのですが、少し書きます。尚、違う記事(アップレード)にて、書いた質問はfirefox記事なので、わたしの質問の答えであれば、こちらでどうぞお願いします。

この前バイナリーで3.5を入れた際、firefoxが起動しませんでした。エラーはちょっと違います。今はremi で入れていますが、アドオンで不備が出る可能性はあります。

ブックマークは当然、バックアップ対象ですよね。とられていることを前提に .mozilla を消してみるのはどうでしょうか?


トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月04日(土) 21:51 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146
# yum updateでOKなら ちゃんちゃん   ですが
# yum reinstall firefox ってダメなんすかね?


トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月05日(日) 22:47 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年11月03日(月) 21:48
記事: 271
こんばんわ、みなさんいろいろとありがとうございます

無事に東京に帰ってきました

まず、xulrunner が入っているかを調べてみました
引用:
[snow@localhost ~]$ su
パスワード:
[root@localhost snow]# yum install xulrunner
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* kde-testing: kdeforge.unl.edu
* livna: wftp.tu-chemnitz.de
* fedora: ftp.riken.jp
* rpmfusion-free-updates: mirror.transact.net.au
* rpmfusion-free: mirror.transact.net.au
* rpmfusion-nonfree-updates: mirror.transact.net.au
* rpmfusion-nonfree: mirror.transact.net.au
* updates: ftp.riken.jp
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: gecko-libs = 1.9.0.10 for package: gtkmozembedmm
--> Processing Dependency: gecko-libs = 1.9.0.10 for package: firefox
---> Package xulrunner.i386 0:1.9.0.11-1.fc10 set to be updated
--> Running transaction check
---> Package firefox.i386 0:3.0.11-1.fc10 set to be updated
--> Processing Dependency: gecko-libs = 1.9.0.10 for package: gtkmozembedmm
--> Finished Dependency Resolution
gtkmozembedmm-1.4.2.cvs20060817-29.fc9.i386 from installed has depsolving problems
--> Missing Dependency: gecko-libs = 1.9.0.10 is needed by package gtkmozembedmm-1.4.2.cvs20060817-29.fc9.i386 (installed)
Error: Missing Dependency: gecko-libs = 1.9.0.10 is needed by package gtkmozembedmm-1.4.2.cvs20060817-29.fc9.i386 (installed)
[root@localhost snow]#


うーんなぜか fc9 という文字がでてきます

firefox のバージョンを調べようとしましたが
引用:
[root@localhost snow]# firefox --version
Couldn't load XPCOM.
[root@localhost snow]#

で表示されません

firefox を再インストールしたらどうかと思ったのですが
引用:
[root@localhost snow]# yum reinstall firefox
Loaded plugins: fastestmirror, refresh-packagekit
Setting up Reinstall Process
Loading mirror speeds from cached hostfile
* kde-testing: mirror.unl.edu
* livna: wftp.tu-chemnitz.de
* fedora: ftp.nchu.edu.tw
* rpmfusion-free-updates: mirror.web-ster.com
* rpmfusion-free: mirror.web-ster.com
* rpmfusion-nonfree-updates: mirror.web-ster.com
* rpmfusion-nonfree: mirror.web-ster.com
* updates: ftp.cuhk.edu.hk
Package firefox-3.0.10-1.fc9.i386 installed and not available
Error: Problem in reinstall: no package matched to install
[root@localhost snow]#

でやはりだめです

次に、
# yum update を実行してみましたが
引用:
Error: Missing Dependency: gecko-libs = 1.9.0.10 is needed by package gtkmozembedmm-1.4.2.cvs20060817-29.fc9.i386 (installed)
[root@localhost snow]#

最後にエラーになります

どうやら、依存関係の問題によるエラー、みたいです

「Error: Problem in reinstall: no package matched to install」
で検索しましたが、見当たらないので

「Error: Missing Dependency」で検索したら けっこう出てきました

ここから先は、いくつか出てきたので、どれにしようか迷っています

では
引用:

既存の パッケージ のバージョンを  rpm -q で確認し
rpm コマンドで 必要なパッケージを直接入れる(バージョンダウンになるなら --oldpackage を付ける)

のような感じです

こちらは CentOSのようです

引用:
どうやら、/etc/yum.repos.d/にある設定が競合?しているらしい。
もうシラミ潰し戦法で行くしかない!!と言うことで、
yum --enablerepo=centosplus --disablerepo=rpmforge update
等を打って、何とかエラーを回避



では
引用:
yum update rpm\* yum\*
yum upgrade


いろいろあり、試してみようと思ったのですが、以前java をインストール「したときに
いろいろやりすぎて、逆に直すのに苦労しました

すみませんが、このような状態になったときの対処法のアドバイスをお願いします


トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月06日(月) 07:44 
オフライン
プライベートメッセージ送信  WWW  プロフィール

登録日時: 2008年9月13日(土) 12:37
記事: 250
所在地: 兵庫県
私の勘違いでなければ、このPCはFedora9からのアップグレードですよね?

これが醍醐味とも言えるんですけれどね。
おそらくはアップグレードの際の不始末でしょう。
他の方々が「新規で入れた方がいい」とあれだけ力説していた理由がなんとなくご理解いただけるのではないでしょうか?(笑)

間違いなくアップグレードの弊害と言いきれませんが、私がそう判断した根拠としては、まず
りなっくす初心者 さんが書きました:
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: gecko-libs = 1.9.0.10 for package: gtkmozembedmm
--> Processing Dependency: gecko-libs = 1.9.0.10 for package: firefox
---> Package xulrunner.i386 0:1.9.0.11-1.fc10 set to be updated
--> Running transaction check
---> Package firefox.i386 0:3.0.11-1.fc10 set to be updated
--> Processing Dependency: gecko-libs = 1.9.0.10 for package: gtkmozembedmm
--> Finished Dependency Resolution
gtkmozembedmm-1.4.2.cvs20060817-29.fc9.i386 from installed has depsolving problems
--> Missing Dependency: gecko-libs = 1.9.0.10 is needed by package gtkmozembedmm-1.4.2.cvs20060817-29.fc9.i386 (installed)
Error: Missing Dependency: gecko-libs = 1.9.0.10 is needed by package gtkmozembedmm-1.4.2.cvs20060817-29.fc9.i386 (installed)

となっている点です。りなっくす初心者さんが「?」と感じておられる通り、Fedora9向けのパッケージなんですよね。依存してるのが。

ほんとに依存してるって事もあるんですが、アップグレード後の場合は単にこいつが更新対象から漏れてて、他のパッケージを巻き込んでいるだけということもままあります。

ちなみに、そういったエラーはメッセージだけで判断できません。ぶっちゃけ経験と勘です。
だからアップグレードは敬遠されるんですけれどね^^;

対処法としては3つ。

1つは時間が解決してくれるパターン。ほんとに依存関係が成り立っており、gtkmozembedmmが更新待ちの場合は時間が解決してくれます。
が、今の状況は、Fedora10がリリースされて十分な時間が経っているからこの可能性は低いでしょう。

2つめは依存関係を訴えているパッケージを更新する。
今回の例ではgtkmozembedmmが依存関係を訴えてますから、こいつを更新してからfirefoxやらなんやらを更新してやります。
(というか、DVDでのアップグレード後にyum updateをやっていなかったのはあまりよろしくないですね。Fedora11へすぐアップグレードするからということだったかも知れませんが、それならそれでさっさとFedora11へあげてしまうべきだったかもしれません。)

3つめは依存しているパッケージを削除してしまう。2の方法で解決できない場合の手です。
ただし、この方法だとこいつが依存している他のパッケージもまとめて削除することになるので、元の状態に戻せなくなる可能性も孕みます。大抵戻りますが。

とりあえずこんなとこです。出社しないといけないので推敲してません。まずい記述があればどなたがご指摘お願いします。


トップへ
 
 記事の件名: Re: アップグレードした fedora 10 で firefox が起動しません
投稿記事Posted: 2009年7月06日(月) 11:25 
オフライン
アバター
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年3月20日(金) 22:04
記事: 239
---------
こんにちは、悩ましい感じですね。お昼を食べながら、サーチしていたのですが、

という記事もあったり、まだサーチが甘いです。

どうですかね。わたしであれば、思い切って gtkmozembedmm を削除 その際、他に 依存して削除されるものをメモする かなです。
雰囲気的にかなり削除されるような・・・・。


トップへ
 
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 19 件の記事 ]  ページ移動 1, 2  次へ

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]


トピック投稿: 不可
返信投稿: 不可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
cron

無料でマイフォーラムを作成する! · php-BB© · Internationalization Project · 不正利用を報告する · 使用条件/プライバシーポリシー
© Forums-Free.com 2009