Fedora Users Forum

Fedoraユーザのためのサポートフォーラム
現在時刻 - 2019年7月21日(日) 16:26

All times are UTC + 9 hours





新しいトピックを投稿する トピックへ返信する  [ 24 件の記事 ]  ページ移動 1つ前へ  1, 2, 3  次へ
作成者 メッセージ
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月22日(月) 23:03 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146
compizの起動は ちょっとお手上げ状態ですが
1つだけ[url]
[/url]
の通りやると
no package compiz-plugins-unsupported available
no package compiz-plugins-extra available
となるんですが rpmのfree non-freeの両方のリポジトリは必要なんでしょうか?nvidiaドライバは必要ないので 関係ないなら今は入れずにおこうと思うんですが :geek:


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月23日(火) 02:12 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
ビデオやmp3のコーデックが必要なくIntelドライバであれば、特にRPM Fusionを追加する必要はないと思います。

compiz-fusion-release-1-6.noarch.rpmが入っていれば、compiz-plugins-unsupportedとcompiz-plugins-extraも入れられると思いますが、その前にCompiz起動しないと…。

というか、Rawhideとか加えちゃうと、修羅場ですよ。


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月23日(火) 05:52 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146
vine_user さんが書きました:
ビデオやmp3のコーデックが必要なくIntelドライバであれば、特にRPM Fusionを追加する必要はないと思います。

compiz-fusion-release-1-6.noarch.rpmが入っていれば、compiz-plugins-unsupportedとcompiz-plugins-extraも入れられると思いますが、その前にCompiz起動しないと…。

というか、Rawhideとか加えちゃうと、修羅場ですよ。


ありがとうございます
# wget
# rpm -Uvh compiz-fusion-release-1-6.noarch.rpm
# rm -f compiz-fusion-release-1-6.noarch.rpm
は通ってるのでOKだとおもうんですが
compiz-plugins-unsupportedとcompiz-plugins-extraは入らないようです

fusion-iconが効かないので
emerald --replace &
とやってもダメなんですが

ただ インストールの時 fusion-iconだけバージョンの数字が違ってたんですが このあたりも原因ですかね?

rpm -qa compiz*
compiz-bcop-0.7.8-2.fc11.noarch
compiz-fusion-0.7.8-8.fc11.i586
compiz-fusion-gnome-0.7.8-8.fc11.i586
compiz-gnome-0.7.8-18.fc11.i586
compiz-0.7.8-18.fc11.i586
compizconfig-python-0.7.8-3.fc11.i586
compizconfig-backend-gconf-0.7.8-2.fc11.i586

rpm -qa fusion-icon
fusion-icon-0.1.0-0.6.5e2dc9git.fc11.noarch
です


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月23日(火) 11:48 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
fusion-iconは独自のバージョンになっているので問題ないですが、compiz-plugins-mainが入っていません。そもそもcompiz-fusion-release-1-6.noarch.rpmを入れたら、バージョン0.8.3が入るはずです。

rpm -qaの結果をみると、0.7.8が入っているようですので、全部削除してから入れ直さないとダメだと思います。

$ su
# yum remove *compiz* fusion-icon emerald*

してから、入れ直してみて下さい。


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月23日(火) 13:38 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146
# wget ... noarch.rpm
# rpm -Uvh compiz-fusion-release-1-6.noarch.rpm
# rm -f compiz-fusion-release-1-6.noarch.rpm
# yum remove *compiz* fusion-icon emerald*
# yum -y --noplugins install compiz-gnome fusion-icon-gtk compiz-bcop ccsm emerald-themes compizconfig-backend-gconf compiz-plugins-unsupported compiz-plugins-extra

でやってみても
0.7.8のものしか入らずplugin-unsupported plugin-extraは入れられない状態です
rpm -qa | grep compiz
compiz-0.7.8-18.fc11.i586
compizconfig-backend-gconf-0.7.8-2.fc11.i586
libcompizconfig-0.7.8-3.fc11.i586
compiz-gnome-0.7.8-18.fc11.i586
compiz-fusion-0.7.8-8.fc11.i586
compizconfig-python-0.7.8-3.fc11.i586
compiz-fusion-gnome-0.7.8-8.fc11.i586
compiz-bcop-0.7.8-2.fc11.noarch
rpm -qa | grep fusion-icon
fusion-icon-gtk-0.1.0-0.6.5e2dc9git.fc11.noarch
fusion-icon-0.1.0-0.6.5e2dc9git.fc11.noarch
rpm -qa | grep emerald
emerald-0.7.8-2.fc11.i586
emerald-themes-0.5.2-3.fc11.noarch
の状態です
glxinfo | grep direct
direct rendering: Yes
ですが グラフィックチップはati radeon IGP340Mなので今回このドライバが必要なんでしょうか?


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月24日(水) 14:39 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
バージョンに関しては,compiz-fusion-release-1-6.noarch.rpmで加わったリポジトリが有効になっていないのではないでしょうか?

「システム>管理>Software Sources」でCompizのリポジトリにチェックが入っているかどうか確認してみて下さい。

あと,Compizが有効にならない理由は,必要なパッケージが揃っていないとなんとも言えません。

ATIのプロプライエタリなドライバ(fglrx)は,以前,XGLを入れないと使えませんでした。その後,確認していませんが,FedoraのXGLは見つからないので,Compizを使うのであれば,fglrxの導入は待ったほうがいいと思います。


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月24日(水) 16:07 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146
vine_user さんが書きました:
バージョンに関しては,compiz-fusion-release-1-6.noarch.rpmで加わったリポジトリが有効になっていないのではないでしょうか?

「システム>管理>Software Sources」でCompizのリポジトリにチェックが入っているかどうか確認してみて下さい。

あと,Compizが有効にならない理由は,必要なパッケージが揃っていないとなんとも言えません。

ATIのプロプライエタリなドライバ(fglrx)は,以前,XGLを入れないと使えませんでした。その後,確認していませんが,FedoraのXGLは見つからないので,Compizを使うのであれば,fglrxの導入は待ったほうがいいと思います。


compizのリポジトリ自体がありませんでした。

コード:
# wget http://www.linux-ati-drivers.homecall.c ... noarch.rpm
# rpm -Uvh compiz-fusion-release-1-6.noarch.rpm
# rm -f compiz-fusion-release-1-6.noarch.rpm

でOKですよね?


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月24日(水) 23:33 
オフライン
Site Admin
アバター
プライベートメッセージ送信  メール  WWW  プロフィール

登録日時: 2008年9月08日(月) 21:17
記事: 428
所在地: 東京都
合ってると思いますけど…。なぜでしょうね?

wgetとrpmのコマンドが終了した時点で,Software Sourcesを確かめていただけますか?

最後のrmで,/etc/yum.repos.d内のrepoファイルが消されたのかも知れないので。というか,compiz.repoがあるかどうか確認するのが先かも?


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年6月25日(木) 06:44 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年9月09日(火) 22:18
記事: 146
vine_user さんが書きました:
合ってると思いますけど…。なぜでしょうね?

wgetとrpmのコマンドが終了した時点で,Software Sourcesを確かめていただけますか?

最後のrmで,/etc/yum.repos.d内のrepoファイルが消されたのかも知れないので。というか,compiz.repoがあるかどうか確認するのが先かも?


未だ fusion-iconも効かず emerald --replace &
compiz --replaceでも立ち上がりません ただ0.8.3バージョンはインストールできました
システム>設定>にcompiz fusionというアイコンができたので enable desktop effectというのをクリックするとまた真っ白になってしまいます

最後のrm -fでリポジトリを消してしまう様です
ただ0.7.8は1回rm-fまでやらないと erase *comiz*で消えないので 消したのち
rm -fを除いたコマンドを実行すると無事0.8.3がはいります

以下が現状です
rpm -qa compiz*
compiz-fusion-release-1-6.noarch
compiz-bcop-0.8.3-1.fc11.noarch
compizconfig-backend-gconf-0.8.3-1.fc11.i586
compiz-0.8.3-3.fc11.i586
compizconfig-python-0.8.3-1.fc11.i586
compiz-plugins-extra-0.8.3-1.fc11.i586
compiz-plugins-unsupported-0.8.3-1.fc11.i586
compiz-gnome-0.8.3-3.fc11.i586
compiz-plugins-main-0.8.3-2.fc11.i586
rpm -qa emerald
emerald-0.8.3-1.fc11.i586
rpm -qa fusion-icon
fusion-icon-0.5-126.fc11.noarch


トップへ
 
 記事の件名: Re: 10から11へのアップグレード compiz起動せずetc 備忘録風に
投稿記事Posted: 2009年7月04日(土) 00:05 
オフライン
アバター
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年3月20日(金) 22:04
記事: 239
---------
まったく参考にならないと思いますが、この前、わたしが失敗した際のことで、やや気になることから書きます。

わたしのグラフィックドライバーはNvidiaなので、まずドライバーをインストールしました。しかし、どうも変なご様子です。というのも、Nvidiaアイコン系がほとんど潰れて (アイコンがない状況です) 、ただし、xorg.confには指定がある! という展開でした。

個人的には 嫌~ な予感がしていたのですが、そのままcompizを入れたところ、真っ白になりました。

そこで、compizを消して、ドライバーも消したんですけど、結局直らず、OSそのものを入れ直しました。その後、compizは正常に動いた展開です。
今、違うosで書いているのですが、確かドライバーは185の前、同士だったので、ドライバーによる問題というより、違う部分にトリガーがある気がします。

クリーンインストールの話で恐縮ですが、わたしはここで、つまづくケースがあるので、最初にドライバー そして compizを入れています。

得意の追記です。



を読むと、vine_userさんが書かれている通り、まだなのかな?と思ったりします。

ただ rawhideが修羅? どんな感じになるんでしょうね(ややわかりません)。ただ、waitっぽい話であることは事実みたいなので、速く出きるといいですね。

↑で書いた内容は、少しだけ前記事を拝読し、少しだけ なるほど と思いました。~/.compizは見当たりませんが、 ~/.localの中とかに、構成情報が残るのかな?です。


トップへ
 
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 24 件の記事 ]  ページ移動 1つ前へ  1, 2, 3  次へ

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]


トピック投稿: 不可
返信投稿: 不可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
cron

無料でマイフォーラムを作成する! · php-BB© · Internationalization Project · 不正利用を報告する · 使用条件/プライバシーポリシー
© Forums-Free.com 2009