Fedora Users Forum

Fedoraユーザのためのサポートフォーラム
現在時刻 - 2019年7月21日(日) 15:40

All times are UTC + 9 hours





新しいトピックを投稿する トピックへ返信する  [ 6 件の記事 ] 
作成者 メッセージ
 記事の件名: firefox-3.6のjava pluginが無効に?
投稿記事Posted: 2009年12月01日(火) 13:20 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年12月01日(火) 13:08
記事: 4
firefox-3.6をfedora rawhideからインストールしました。
設定メニューに「javaを有効にする」チェックボックスがありません。
またjavaのプラグインも有効ではありません。
mozilla本家のfirefox-3.6も試しましたが同様に不可です。
どなたか対処法をご存知ありませんか?

追伸
firefox-3.5.5ではOKでした。
OS: linux-2.6.32-0.58.i686.fc13


トップへ
 
 記事の件名: Re: firefox-3.6のjava pluginが無効に?
投稿記事Posted: 2009年12月03日(木) 19:59 
オフライン
プライベートメッセージ送信  WWW  プロフィール

登録日時: 2008年9月13日(土) 12:37
記事: 250
所在地: 兵庫県

より。
引用:
オプション/設定画面のコンテンツのパネルから、「Javaを有効にする」のチェックボックスが削除されました。その代わり、ツールメニューのアドオンマネージャからJavaを無効にできます。(Bug 506985)

だそうです。
確認なさってみては?


トップへ
 
 記事の件名: Re[2]: firefox-3.6のjava pluginが無効に?
投稿記事Posted: 2009年12月05日(土) 13:06 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年12月01日(火) 13:08
記事: 4
確認しました。
アドオンマネージャのプラグインにjava pluginが表示されません。
firefox-3.6以上では永久にjavaは使用できないのかもしれないですね。


トップへ
 
 記事の件名: Re: firefox-3.6のjava pluginが無効に?
投稿記事Posted: 2009年12月05日(土) 14:27 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2008年11月03日(月) 21:48
記事: 271
「Firefox 3.6 Beta 1」リリース
Personasやプラグインチェックをネイティブサポート


によると
引用:
 Firefox 3.6では、現行バージョンでは追加機能だったスキン着せ替えアドオン「Personas」や、外部サイトに頼っていたプラグインチェックがネイティブにサポートされている。また、<video>タグ動画のフルスクリーン表示やポスターフレーム、WOFF(Web Open Font Format)形式のWebフォントなどに対応し、JavaScriptの性能向上も図られている

とのことです

おーぷんそーす日記™ 3.0
Mozilla Firefox 3.6以降でJavaを使うには


によりますと

Mozilla Firefox 3.6以降でJavaを使うには
Java 6 Update 10以降 (要するにNew Plugin) が必要
従来のプラグインで使っていたインターフェース (OJI) が取っ払われたためらしいですね



をみてみたのですが
引用:
Firefox 3.6 以降では、Java Version 6 Update 10 以降を実行していない場合、Java ベースのアプリケーションは動作しません。
Firefox 3.6 以降では、Mozilla Foundation は OJI (Open Java 仮想マシンの統合) のサポートを廃止し、
今後は、標準の NPAPI および NPRuntime インタフェースだけをサポートしていく予定です。
Java Version 6 Update 10 以降のバージョンに含まれている Java プラグインは、
NPAPI および NPRuntime のインタフェースをサポートしています。
このため、Firefox 3.6 以降では、Java Version 6 Update 10 以降を実行していない場合、
Java ベースのアプレットは動作しません。


とかかれていますので、最新のjava が入っていないと java が使えないみたいです


トップへ
 
 記事の件名: Re: firefox-3.6のjava pluginが無効に?
投稿記事Posted: 2009年12月05日(土) 16:27 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年12月01日(火) 13:08
記事: 4
りなっくす初心者 さんが書きました:
「Firefox 3.6 Beta 1」リリース
Personasやプラグインチェックをネイティブサポート


によると
引用:
 Firefox 3.6では、現行バージョンでは追加機能だったスキン着せ替えアドオン「Personas」や、外部サイトに頼っていたプラグインチェックがネイティブにサポートされている。また、<video>タグ動画のフルスクリーン表示やポスターフレーム、WOFF(Web Open Font Format)形式のWebフォントなどに対応し、JavaScriptの性能向上も図られている

とのことです

おーぷんそーす日記™ 3.0
Mozilla Firefox 3.6以降でJavaを使うには


によりますと

Mozilla Firefox 3.6以降でJavaを使うには
Java 6 Update 10以降 (要するにNew Plugin) が必要
従来のプラグインで使っていたインターフェース (OJI) が取っ払われたためらしいですね



をみてみたのですが
引用:
Firefox 3.6 以降では、Java Version 6 Update 10 以降を実行していない場合、Java ベースのアプリケーションは動作しません。
Firefox 3.6 以降では、Mozilla Foundation は OJI (Open Java 仮想マシンの統合) のサポートを廃止し、
今後は、標準の NPAPI および NPRuntime インタフェースだけをサポートしていく予定です。
Java Version 6 Update 10 以降のバージョンに含まれている Java プラグインは、
NPAPI および NPRuntime のインタフェースをサポートしています。
このため、Firefox 3.6 以降では、Java Version 6 Update 10 以降を実行していない場合、
Java ベースのアプレットは動作しません。


とかかれていますので、最新のjava が入っていないと java が使えないみたいです

java version 6 update 17をインストールしています。
/usr/lib/mozilla/plugin/libjava_oji.soをリンクしています。
これではいけないわけですね。
では、NPRuntimeというのはどこにあるのでしょうか?


トップへ
 
 記事の件名: Re: firefox-3.6のjava pluginが無効に?
投稿記事Posted: 2009年12月05日(土) 16:44 
オフライン
プライベートメッセージ送信  メール  プロフィール

登録日時: 2009年12月01日(火) 13:08
記事: 4
---------
いろいろありがとうございました。以下のようにして解決しました。
npruntimeはjre/lib/i386/libjpnp2.soにありました。

/usr/lib/mozilla/pluginsで
libjavaplugin_oji.soを削除し
上記 libjpnp2.soのリンクを作成しました。
結果、アドオンマネージャにjava pluginが表示され
appletも実行できました。


トップへ
 
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 6 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]


トピック投稿: 不可
返信投稿: 不可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
cron

無料でマイフォーラムを作成する! · php-BB© · Internationalization Project · 不正利用を報告する · 使用条件/プライバシーポリシー
© Forums-Free.com 2009